Email Delivery

Incident Report for Street Contxt

Resolved

This incident has been resolved.
Posted May 08, 2026 - 03:49 EDT

Update

Email delivery continues to flow normally. The issue is now considered resolved.

Any users affected by this issue have been notified individually.
Posted May 08, 2026 - 03:34 EDT

Monitoring

The root cause has been identified and fixed. We are now reviewing to ensure whether any email needs to be resent. Any affected users will be notified as such.
Posted May 08, 2026 - 01:45 EDT

Investigating

Some users are experiencing an issue with email delivery. We are currently investigating the root cause and are working to resolve.
Posted May 08, 2026 - 01:07 EDT
This incident affected: Email Delivery.